Smite PC Matchmaking
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 25 days ago. Jul 27, 2018 - 23:08 EDT
Monitoring
The issue has been addressed, and logins have resumed. We will continue to monitor.
Posted 25 days ago. Jul 27, 2018 - 22:40 EDT
Identified
We will be temporarily pausing logins to address the issue.
Posted 25 days ago. Jul 27, 2018 - 22:34 EDT
Investigating
There is currently an issue that is affecting matchmaking on Smite PC. We are investigating.
Posted 25 days ago. Jul 27, 2018 - 22:32 EDT
This incident affected: Smite (Smite PC).