Smite PC - Match Manager Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This #Smite #PC Match Manager issue has been resolved.
Posted 6 months ago. Jun 27, 2018 - 14:41 EDT
Investigating
We are currently investigating an issue with #Smite #PC Match Manager
Posted 6 months ago. Jun 27, 2018 - 12:31 EDT
This incident affected: Smite (Smite PC).