Currently experiencing network issues with both environments. Will update when we have a resolution.
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted over 1 year ago. Oct 15, 2015 - 22:24 EDT
Update
This issue has been resolved.
Posted over 1 year ago. Oct 15, 2015 - 22:24 EDT
Investigating
We are currently investigating this issue.
Posted over 1 year ago. Oct 15, 2015 - 21:49 EDT