Paladins Crossplay Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 17 days ago. Jun 03, 2019 - 01:51 EDT
Monitoring
The #Paladins #PC, #Switch, & #Xbox emergency restart has been completed. We are monitoring the results.
Posted 17 days ago. Jun 03, 2019 - 01:33 EDT
Investigating
We are performing an emergency restart for #Paladins #PC, #Switch, & #Xbox. Game will be back up soon.
Posted 17 days ago. Jun 03, 2019 - 01:19 EDT
This incident affected: Paladins (Paladins PC, Paladins Xbox, Paladins Switch).