Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 5 months ago. Nov 15, 2016 - 10:18 EST
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted 5 months ago. Nov 15, 2016 - 07:16 EST