Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Issue with Paladins PC has recovered.
Posted 12 months ago. Dec 22, 2016 - 13:06 EST
Identified
We are currently looking in to #PALADINS PC issues.
Posted 12 months ago. Dec 22, 2016 - 12:59 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 12 months ago. Dec 22, 2016 - 12:54 EST
This incident affected: Paladins PC.