Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#Smite #XBox restart has been completed. We will continue to monitor the environment.
Posted about 1 month ago. Jul 11, 2017 - 13:15 EDT
Update
We will be restarting #Smite #XBox momentarily
Posted about 1 month ago. Jul 11, 2017 - 13:03 EDT
Identified
We are investigating an issue with #Smite #XBox
Posted about 1 month ago. Jul 11, 2017 - 12:59 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted about 1 month ago. Jul 11, 2017 - 12:56 EDT
This incident affected: Smite Xbox - North America / Europe.