We will be pausing logins for a few moments on Paladins PC to restart a component of the game
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This paladins pc incident has been resolved. #paladinspc
Posted 23 days ago. Apr 07, 2017 - 10:37 EDT
Investigating
We will be pausing logins for a few moments on Paladins PC to restart a component of the game #PaladinsPC
Posted 23 days ago. Apr 07, 2017 - 10:28 EDT
This incident affected: Paladins PC.