Smite Login Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted May 08, 2022 - 23:54 EDT
Monitoring
A fix has been implemented and we are opening the game once more.
Posted May 08, 2022 - 23:26 EDT
Identified
The issue has been identified and we are working on the fix now.
Posted May 08, 2022 - 22:48 EDT
Investigating
#Smite is currently experiencing some login issues and we are working on getting this corrected as soon as possible.
Posted May 08, 2022 - 22:33 EDT
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch, SMITE Epic).