Rogue Company Connectivity Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This #RogueCompany connectivity issue has been resolved.
Posted Jun 17, 2022 - 07:11 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 17, 2022 - 02:16 EDT
Investigating
We are currently investigating this issue.
Posted Jun 17, 2022 - 01:03 EDT
This incident affected: Rogue Company (Rogue Company PC, Rogue Company PS4, Rogue Company Xbox, Rogue Company Switch, Rogue Company Epic).