Divine Knockout Steam Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Mar 12, 2023 - 21:40 EDT
Monitoring
Logins have resumed for #DivineKnockout via. Steam
Posted Mar 12, 2023 - 17:28 EDT
Investigating
We are investigating an issue that is affecting player trying to login to #DivineKnockout via. Steam.
Posted Mar 12, 2023 - 16:50 EDT
This incident affected: Divine Knockout (Divine Knockout Steam, Divine Knockout PS4, Divine Knockout Xbox, Divine Knockout Epic).