Epic Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Sep 30, 2022 - 20:11 EDT
Update
We are continuing to investigate this issue.
Posted Sep 30, 2022 - 18:03 EDT
Investigating
We are currently investigating this issue.
Posted Sep 30, 2022 - 18:02 EDT
This incident affected: Rogue Company (Rogue Company Epic), Realm Royale Reforged (Realm Royale Epic), Paladins (Paladins Epic), and SMITE (SMITE Epic).