Paladins PS4 Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
The restart is now complete
Posted Apr 21, 2019 - 00:08 EDT
Identified
We will be performing an emergency restart of #Paladins #PS4. The game will be back shortly.
Posted Apr 20, 2019 - 23:50 EDT
This incident affected: Paladins (Paladins PS4).