Rogue Company Logins Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Jul 20, 2021 - 13:50 EDT
Monitoring
We have implemented a fix for this #RogueCompany issue and are currently monitoring the results.
Posted Jul 20, 2021 - 13:06 EDT
Investigating
We are currently investigating this issue.
Posted Jul 20, 2021 - 09:56 EDT
This incident affected: Rogue Company (Rogue Company PC, Rogue Company PS4, Rogue Company Xbox, Rogue Company Switch, Rogue Company Epic).