Realm Royale Server Maintenance
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Dec 09, 2021 - 05:25 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 09, 2021 - 05:12 EST
Investigating
we are restarting Realm Royale at this time.
Posted Dec 09, 2021 - 05:03 EST
This incident affected: Realm Royale (Realm Royale PC, Realm Royale PS4, Realm Royale Xbox, Realm Royale Switch).