Smite Crossplay Match Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This #Smite issue has been resolved.
Posted Sep 22, 2021 - 13:47 EDT
Monitoring
We have implemented a solution for this and are currently monitoring the results. Logins have resumed.
Posted Sep 22, 2021 - 13:05 EDT
Identified
We have identified an issue with the PLAY button not working. We are temporarily limiting logins while we work on this issue at this time and apologize for the inconvenience.
Posted Sep 22, 2021 - 12:51 EDT
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch, SMITE Epic).