Rogue Company Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Oct 04, 2020 - 17:26 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 04, 2020 - 17:26 EDT
Identified
We will be restarting Rogue Company momentarily to address the login issue. We apologize for any inconvenience that this may have caused.
Posted Oct 04, 2020 - 16:15 EDT
Investigating
We are currently investigating player login issues to Rogue Company at this time
Posted Oct 04, 2020 - 16:07 EDT
This incident affected: Rogue Company (Rogue Company PC, Rogue Company PS4, Rogue Company Xbox, Rogue Company Switch, Rogue Company Epic).