Divine Knockout Server Maintenance
Incident Report for Hi-Rez Studios, Inc
Resolved
This #DivineKnockout server maintenance has been completed!
Posted Dec 05, 2022 - 15:26 EST
Identified
We are performing a brief server maintenance on #DivineKnockout at this time. We will update accordingly and apologize for the inconvenience.
Posted Dec 05, 2022 - 15:06 EST
This incident affected: Divine Knockout (Divine Knockout Steam, Divine Knockout PS4, Divine Knockout Xbox, Divine Knockout Epic).