Smite Matchmaking Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Oct 28, 2021 - 10:57 EDT
Monitoring
Logins and matchmaking have resumed for #SMITE.
Posted Oct 28, 2021 - 10:41 EDT
Investigating
We are currently investigating an issue that is affecting matchmaking for #SMITE. Logins have been limited in the meantime.
Posted Oct 28, 2021 - 10:30 EDT
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch, SMITE Epic).