Smite Login Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Apr 03, 2022 - 09:31 EDT
Identified
Smite is currently experiencing some login issues and we are working on getting this corrected as soon as possible.
Posted Apr 03, 2022 - 08:27 EDT
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch, SMITE Epic).