Smite Matchmaking Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Jun 30, 2021 - 21:08 EDT
Monitoring
Matchmaking and logins have resumed for #SMITE. We will continue to monitor.
Posted Jun 30, 2021 - 20:48 EDT
Investigating
We are investigating an issue that is preventing matches from launching in #SMITE. We are working to return matchmaking services back to normal. Logins will be limited in the meantime.
Posted Jun 30, 2021 - 20:32 EDT
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch, SMITE Epic).