Smite, Paladins, Realm Royale Game issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Apr 03, 2022 - 07:34 EDT
Update
Smite is back online we will continue to monitor.
Posted Apr 03, 2022 - 05:28 EDT
Identified
Paladins is back online we will continue to monitor.
Posted Apr 03, 2022 - 05:23 EDT
Update
We will be performing Emergency Restarts on the following games: Smite, Paladins, Realm Royale.
Posted Apr 03, 2022 - 04:32 EDT
Investigating
We are investigating an issue that is affecting logins for #Smite #Paladins #RealmRoyale.
Posted Apr 03, 2022 - 04:12 EDT
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch, SMITE Epic), Realm Royale (Realm Royale PC, Realm Royale PS4, Realm Royale Xbox, Realm Royale Switch), and Paladins (Paladins PC, Paladins PS4, Paladins Xbox, Paladins Switch, Paladins Epic).