Rogue Company Match Making Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Aug 29, 2020 - 01:40 EDT
Monitoring
The issue affecting matchmaking on #RogueCompany has been addressed, and queues have resumed. We will continue to monitor the results.
Posted Aug 28, 2020 - 22:22 EDT
Investigating
We are currently investigating and issue that is affecting match making on #RogueCompany
Posted Aug 28, 2020 - 21:47 EDT
This incident affected: Rogue Company (Rogue Company PC, Rogue Company PS4, Rogue Company Xbox, Rogue Company Switch, Rogue Company Epic).