Rogue Company Service Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Oct 30, 2021 - 12:21 EDT
Monitoring
Game services have recovered for #RogueCompany. We are continuing to monitor.
Posted Oct 30, 2021 - 09:55 EDT
Investigating
We are investigating an issue that is affecting our live game services for #RogueCompany.
Posted Oct 30, 2021 - 09:05 EDT
This incident affected: Rogue Company (Rogue Company PC, Rogue Company PS4, Rogue Company Xbox, Rogue Company Switch, Rogue Company Epic).