Paladins Xbox/Switch Match Manager Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This #Paladins #Xbox and #Switch issue has been resolved.
Posted 4 months ago. Aug 08, 2018 - 12:00 EDT
Investigating
We are currently looking into issues with the #Paladins #Xbox and #Switch Match Manager.
Posted 4 months ago. Aug 08, 2018 - 11:19 EDT
This incident affected: Paladins (Paladins Xbox).