Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This incident has been resolved. #smite
Posted 9 months ago. Nov 10, 2016 - 23:13 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 9 months ago. Nov 10, 2016 - 21:22 EST
Update
#Smite on #Xbox is currently undergoing an emergency restart.
We apologize for the inconvenience.
Posted 9 months ago. Nov 10, 2016 - 21:11 EST
Identified
Live issue with #SMITE XBox that will require an emergency restart; restart is underway; apologies on the inconvenience.
Posted 9 months ago. Nov 10, 2016 - 21:11 EST
Update
#Smite on #Xbox is currently undergoing an emergency restart.
We apologize for the inconvenience.
Posted 9 months ago. Nov 10, 2016 - 21:10 EST
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 9 months ago. Nov 10, 2016 - 21:02 EST