Smite Crossplay Login Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This #Smite #PC, #Switch, & #Xbox issue has been resolved.
Posted 4 months ago. May 02, 2019 - 06:59 EDT
Investigating
We are currently investigating an issue players are having logging into Smite Crossplay. Thank you for your patience while we get this fixed.
Posted 4 months ago. May 01, 2019 - 15:51 EDT
This incident affected: Smite (Smite PC, Smite Xbox, Smite Switch).