Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite incident has been resolved#smite
Posted 11 months ago. Sep 14, 2016 - 15:40 EDT
Identified
Steam is currently experiencing issues which may impact logins or purchasing through steam on #Smite PC.
Posted 11 months ago. Sep 14, 2016 - 12:47 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 11 months ago. Sep 14, 2016 - 12:43 EDT