Paladins Crossplay Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 18, 2019 - 14:48 EDT
Monitoring
We have implemented a fix for this #Paladins #Crossplay issue and are currently monitoring the results.
Posted about 1 month ago. Jul 18, 2019 - 14:36 EDT
Update
We are continuing to investigate this issue.
Posted about 1 month ago. Jul 18, 2019 - 14:13 EDT
Investigating
We are currently investigating issues with Paladins Crossplay logins
Posted about 1 month ago. Jul 18, 2019 - 13:54 EDT
This incident affected: Paladins (Paladins PC, Paladins Xbox, Paladins Switch).