Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue with #Smite #Xbox has been resolved.
Posted Jul 22, 2017 - 12:22 EDT
Monitoring
We have fixed an issue to #Smite #Xbox and will continue to monitor closely
Posted Jul 22, 2017 - 12:19 EDT
Identified
We have identified an issue with #Smite #Xbox and are working on bringing services back to normal
Posted Jul 22, 2017 - 12:15 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted Jul 22, 2017 - 12:07 EDT
This incident affected: SMITE (SMITE Xbox).