Realm Royale PC & Xbox Login Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This #RealmRoyale #PC & #Xbox issue has been resolved.
Posted 6 days ago. Mar 13, 2019 - 15:15 EDT
Monitoring
The #RealmRoyale #PC & #Xbox emergency maintenance has been completed. We are monitoring the results.
Posted 6 days ago. Mar 13, 2019 - 14:49 EDT
Identified
We are performing an emergency maintenance on #RealmRoyale #PC & #Xbox to address the issue.
Posted 6 days ago. Mar 13, 2019 - 14:30 EDT
Investigating
We are currently investigating a login issue with #RealmRoyale #PC & #Xbox.
Posted 6 days ago. Mar 13, 2019 - 14:17 EDT
This incident affected: Realm Royale (Realm Royale PC, Realm Royale Xbox).