Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
We have resumed logins, matchmaking has been restored.
Posted 3 months ago. Jan 04, 2017 - 16:45 EST
Identified
We are working to restore Matchmaking for #Smite on #XBox.
Posted 3 months ago. Jan 04, 2017 - 16:36 EST
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 3 months ago. Jan 04, 2017 - 16:33 EST
This incident affected: Smite Xbox - North America / Europe.