Hand of the Gods Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 9 months ago. Mar 14, 2018 - 04:28 EDT
Monitoring
The emergency restart for #HandofTheGods #PS4 has been completed. We are monitoring the results.
Posted 9 months ago. Mar 14, 2018 - 04:11 EDT
Identified
We are performing an emergency restart for #HandofTheGods #PS4. Game will be back up shortly.
Posted 9 months ago. Mar 14, 2018 - 03:59 EDT
This incident affected: Hand of the Gods (Hand of the Gods PS4).