Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 11 months ago. Aug 13, 2016 - 16:53 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 11 months ago. Aug 13, 2016 - 16:44 EDT