Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This Smite PC incident has been resolved. #SmitePC
Posted 5 months ago. Mar 18, 2017 - 20:20 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted 5 months ago. Mar 18, 2017 - 20:17 EDT
Update
We are currently investigating this Smite PC issue. #SmitePC
Posted 5 months ago. Mar 18, 2017 - 19:48 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 5 months ago. Mar 18, 2017 - 19:46 EDT