Hi-Rez - All products momentarily impacted
Incident Report for Hi-Rez Studios, Inc
Resolved
All Hi-Rez products have returned to normal operations. #Smite #Paladins #Tribes
Posted 3 months ago. Jun 07, 2017 - 15:20 EDT
Monitoring
We experienced a network event that momentarily impacted all products; at this time, all games are returning to normal; we are continuing to monitor. #Smite #Paladins #Tribes
Posted 3 months ago. Jun 07, 2017 - 15:09 EDT
This incident affected: Smite PC - North America / Europe, Smite Xbox - North America / Europe, Smite PS4 - North America / Europe, Paladins PC, Paladins Xbox, Paladins PS4, Tribes Ascend, and Smite Tactics.