Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 9 months ago. Dec 31, 2017 - 01:52 EST
Update
The issue with #Smite #PC has been resolved.
Posted 9 months ago. Dec 31, 2017 - 01:52 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 9 months ago. Dec 31, 2017 - 01:19 EST
This incident affected: Smite (Smite PC).