Smite Matchmaking Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Apr 02, 2021 - 20:56 EDT
Monitoring
Logins and matchmaking have resumed for #Smite. We will continue to monitor.
Posted Apr 02, 2021 - 20:44 EDT
Investigating
We are investigating an issue that is affecting matchmaking on #Smite. Logins will be limited at this time.
Posted Apr 02, 2021 - 19:49 EDT
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch, SMITE Epic).