Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Paladins PC incident has been resolved. #PaladinsPC
Posted 4 months ago. Apr 17, 2017 - 22:05 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 4 months ago. Apr 17, 2017 - 22:00 EDT
This incident affected: Paladins PC.