Smite PC Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
#SMITE PC Login issues have been resolved
Posted about 2 years ago. Dec 16, 2015 - 11:16 EST
Update
We are restarting the servers
Posted about 2 years ago. Dec 16, 2015 - 09:44 EST
Investigating
We are investigating #Smite
Posted about 2 years ago. Dec 16, 2015 - 09:37 EST