Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 month ago. Apr 08, 2018 - 23:52 EDT
Monitoring
We seem to be recovering from the issue on #SMITE #XBOX. We will continue to monitor the situation.
Posted about 1 month ago. Apr 08, 2018 - 21:39 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted about 1 month ago. Apr 08, 2018 - 20:59 EDT
This incident affected: Smite Xbox - North America / Europe.