Smite Xbox Client Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 26 days ago. Jun 25, 2019 - 14:12 EDT
Update
We are still working on issues with the Smite Xbox client.
Posted 26 days ago. Jun 25, 2019 - 12:05 EDT
Identified
We are currently working on resolving issues with the #Smite #Xbox client.
Posted 26 days ago. Jun 25, 2019 - 09:57 EDT
This incident affected: Smite (Smite Xbox).