Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 5 months ago. Jan 14, 2017 - 23:34 EST
Identified
We have detected possible issues with PSN services which may be affecting logins for #Smite on #PS4.
Posted 5 months ago. Jan 14, 2017 - 23:16 EST
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted 5 months ago. Jan 14, 2017 - 23:04 EST
This incident affected: Smite PS4 - North America / Europe.