Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#Paladins #PC has recovered.
Posted about 1 year ago. Jun 16, 2017 - 10:27 EDT
Monitoring
Logins have resumed and we will continue to monitoring #Paladins #PC
Posted about 1 year ago. Jun 16, 2017 - 10:09 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted about 1 year ago. Jun 16, 2017 - 09:49 EDT