Paladins PC - Limited Access
Incident Report for Hi-Rez Studios, Inc
Resolved
Logins are no longer limited in #PaladinsPC. Apologies for the inconvenience.
Posted 5 months ago. Mar 22, 2017 - 15:46 EDT
Identified
We are limiting logins for a short time to address an issue.
Posted 5 months ago. Mar 22, 2017 - 15:41 EDT
This incident affected: Paladins PC.