Smite/Paladins/Realm Royale Xbox Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 22 days ago. Feb 01, 2019 - 12:59 EST
Identified
Players may be experiencing issues with #Smite, #Paladins, and/or #RealmRoyale #Xbox due to ongoing Xbox Live issues.

More information can be found here: https://support.xbox.com/en-US/xbox-live-status
Posted 22 days ago. Feb 01, 2019 - 11:16 EST
This incident affected: Paladins (Paladins Xbox), Smite (Smite Xbox), and Realm Royale (Realm Royale Xbox).