Possible Xbox Store Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 2 months ago. Oct 06, 2018 - 05:40 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. Oct 06, 2018 - 04:49 EDT
Investigating
We are currently experiencing issues with Xbox Store purchases and are looking into it.
Posted 2 months ago. Oct 06, 2018 - 01:46 EDT
This incident affected: Smite (Smite Xbox), Hand of the Gods (Hand of the Gods Xbox), and Paladins (Paladins Xbox).