Paladins PS4 Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 18, 2019 - 01:34 EDT
Monitoring
The restart has been completed.
Posted about 1 month ago. Jul 18, 2019 - 01:28 EDT
Investigating
We are performing an emergency restart on Paladins PS4
Posted about 1 month ago. Jul 18, 2019 - 00:37 EDT
This incident affected: Paladins (Paladins PS4).