Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PS4 incident has been resolved #SmitePS4
Posted 10 days ago. May 14, 2017 - 22:31 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted 10 days ago. May 14, 2017 - 22:18 EDT
This incident affected: Smite PS4 - North America / Europe.