Paladins PS4 Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 24, 2019 - 08:27 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 month ago. Jul 24, 2019 - 08:18 EDT
Investigating
We are performing an emergency restart on Paladins PS4, we apologies for the inconvenience.
Posted about 1 month ago. Jul 24, 2019 - 08:13 EDT
This incident affected: Paladins (Paladins PS4).